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1 Introduction 

1.1 About This Document 

This is a Getting Started document describing how to perform common application packaging 

tasks with help of Infopulse PACE Suite. 

 

1.2 Glossary 

MSI 

MSI is an installer package file format used by Windows. Its name comes from the 

program's original title, Microsoft Installer, which has changed to Windows Installer. 

MSI files are used for installation, storage, and removal of programs. 

MST 

MST is a settings file used by Microsoft Windows Installer, a component of the 

Windows operating system that enables software installations. It contains software 

configuration options, allows custom parameters for the installation. 

App-V 

Microsoft Application Virtualization (also known as App-V; formerly Softricity 

SoftGrid) is an application virtualization and application streaming solution from 

Microsoft. 
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2 PACE Overview 
PACE Suite consists of the following components: 

 

 Repackage any existing installation into Windows Installer or a 

virtual format (Microsoft App-V 5.x, and VMware ThinApp). 

 Auto-detection of embedded installers. 

 Tune any existing Windows Installer package by applying your 

settings and saving them as a Windows Installer transform (MST). 

 Include the excluded files/registry back to a package. 

 

 Manage the contents of an MSI in a tree view 

 Import the desired resources 

 Edit and manage Custom Actions 

 Integrate scripts into your package 

 Use a smart and advanced MSI database editor, with formatted 

string autocompleting, Excel-like formula bar, row reference 

tracking, and more. 

 Create patches (MSP) 

 Handle upgrades easily – just let MSI Editor know which MSI you 

want to be upgraded at runtime. 

 Publish your applications to Microsoft SCCM 2007 or 2012. 

 See the estimated complexity of an app right away. 

 Generate package documentation containing the details about 

your package and configuration. 

 Undo-redo any manipulation and see the changes highlighted in 

the MSI tables 

 

 Automatically record your on-screen actions into a nice-looking 

document with screenshots and annotations 
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2.1 Installation & System Requirements 

2.1.1 Software Prerequisites 
Ensure that a target system contains necessary software prerequisites: 

OS Windows 10/8.1/8/7 SP1, Windows Server 2012/2008 R2 SP1 

Middleware 
Microsoft .NET Framework 4.6.1 (https://www.microsoft.com/en-

us/download/details.aspx?id=49981) or higher. 

Privileges Administrative privileges on the system. 

 

2.1.2 Hardware Prerequisites 
Ensure that a target system fulfils the minimum hardware conditions: 

Processor 

32-bit (x86) or 64-bit (x64) processor at 2 GHz or greater 

NOTE To repackage 64-bit applications or create 64-bit App-V packages, use 

PACE Suite on a 64-bit Windows operating system. 

RAM 2 GB 

Hard drive 

free space 

1 GB 

NOTE Additional storage is required for your projects and packages and 

depends on their size and quantity. 

Display 1280 x 768 resolution or higher. 

 

  

https://www.microsoft.com/en-us/download/details.aspx?id=49981
https://www.microsoft.com/en-us/download/details.aspx?id=49981
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2.1.3 PACE Suite Installation (MSI Package) 
This type of installation is recommended as the minimum requirements are checked during the 

installation. On the other hand, installation requires the administrator privileges on the system. 

[1]. Locate the downloaded PACE Suite installation package on your filesystem 

[2]. Run the PACE Suite installation package. 

[3]. Click “Next” on the welcome screen. 

 

[4]. Read and accept the END USER LICENSE AGREEMENT and click “Next”. 
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[5]. Keep the default file location or change it if needed and click “Next”.  

 

[6]. Enter your License Key or select “Skip entering a product key now” and click “Next”  
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[7]. Select the PACE components and file type associations you want to install and click “Next”.  

 

[8]. Click the “Install” button to start the installation 

 

[9]. If you have User Account Control enabled, click the “Yes” button in the UAC window. 
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[10]. Wait till the installation completion 

 

[11].  Click “Finish” to close the installation wizard. 

 

Find the PACE Suite shortcuts on your Desktop and in the Start Menu 

   



Getting Started 
PACE Suite 4.1 

pg. 12 

2.1.4 Using Portable Distributive (ZIP Archive) 
NOTE Please ensure that your system fulfils the necessary conditions for running PACE Suite. 

[1]. Locate the downloaded PACE Suite ZIP archive on your filesystem 

[2]. Select the “Extract All…” action from the Windows Explorer context menu for the PACE Suite 

ZIP archive 

 

[3]. Specify the location where you want to extract PACE Suite to. 

 

PACE Suite ZIP archive contains the following resources: 

 

- For launching MSI Generator use in the MSI Generator folder 

- For launching MSI Editor use in the MSI Editor folder 

- For launching Docu Generator use  in the Docu Generator folder 
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3 How-To 

3.1 Create a Blank MSI Package 

[1]. Launch MSI Editor 

 

[2]. Select “New MSI…” from the MENU 
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[3]. Specify the name and the destination folder for the new MSI and click Save 

 

 

3.2 Create a Blank MST for an Existent MSI Package 

[1]. Launch MSI Editor 
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[2]. Select “Open…” from the MENU 

 

[3]. Select an MSI package, for which a new MST will be created and click Open 
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[4]. Select “New MST…” from the MENU 

 

[5]. Specify the name of new transform and click Save 

 

[6]. Make the desired changes, which will be saved to the transform (MST) file. 
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3.3 Create an App-V 5.x Package from Scratch 

[1]. Launch MSI Generator 

 

[2]. If you have User Account Control enabled, click the “Yes” button in the opened UAC 

window  

 

[3]. Select Create Package 
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[4]. Click the “Blank Package” button 

 

[5]. Enter the package name and click Create 

 

[6]. The created package will be opened for editing, where you can import files, registry, 

shortcuts and change package options according to your needs (see instructions on how to 

Edit an Existent Package File). 

In order to build an App-V package, open the “Package” tab, select the “App-V” tab of the 
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second level and click the “Build App-V” button. 

 

 

3.4 Repackage EXE to MSI Package 

[1]. Launch MSI Generator 
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[2]. If you have User Account Control enabled, click the “Yes” button in the opened UAC 

window  

 

[3]. Select Create Package 

 

[4]. Select the repackaging method, where “Monitoring” is a faster method and “Snapshots” is 

more configurable one and click the “Repackage” button. The following “Snapshots” options 
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appear on the screen. 

 

[5]. Wait for the First System Snapshot creation. At this stage, you can deselect system areas 

(local drives, registry hives, etc.), which will not be scanned for changes. 

 

Once the First System Snapshot has been created, the process continues with the next step. 

[6]. Perform a source installation (EXE, Script, etc.) you need to repackage and click the “Finish 

capturing” button. Note, that MSI packages, wrapped into EXE, will be displayed in 

“Detected MSI installations” tab. 
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Wait for the Second System Snapshot creation. 

[7]. The created package will be opened for editing, where you can exclude redundant 

resources, import files, registry, shortcuts and change package options according to your 

needs (see instructions on how to Edit an Existent Package File). 

In order to build an MSI package, open the “Package” tab, select the “MSI” tab of the 

second level and click the “Build MSI” button. 
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3.5 Create a Response MST 

[1]. Launch MSI Generator 

 

[2]. If you have User Account Control enabled, click “Yes” in the UAC window  

 

[3]. Select “Create package” 
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[4]. Select “Monitoring” option and click the “Repackage” button. 

 

[5]. Perform an installation of the MSI package, for which you want to create a response 

transform and click the “Finish capturing” button. 

 

[6]. Open the “Package” tab, select the “MST” tab of the second level, set necessary transform 

options and click the “Build MST” button. 

Using checkboxes in the Transform section you can choose which resources will be included 
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into transform (MST). 

 

 

3.6 Repackage EXE to App-V 5.x 

[1]. Follow the instructions on how to Repackage EXE to MSI Package from step 1 to 6. 

[2]. The created package will be opened for editing, where you can exclude redundant 

resources, import files, registry, shortcuts and change package options such as FTAs, folders 

and registry keys virtualization levels, streaming options, PVAD, App-V version and others 

(see instructions on how to Edit an Existent Package File). 

In order to build an App-V package, open the “Package” tab, select the “App-V” tab of the 
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second level and click the “Build App-V” button. 

 

 

3.7 Repackage EXE to ThinApp 

NOTE Ensure that the target system contains necessary software: 

Prerequisites VMware ThinApp (5.0.0/5.0.1/5.1.0/5.1.1/5.2.0) 

 

[1]. Follow the instructions on how to Repackage EXE to MSI Package from step 1 to 6. 

[2]. The created package will be opened for editing, where you can import files, registry, 

shortcuts and change package options according to your needs (see instructions on how to 

Edit an Existent Package File). 

In order to build an App-V package, open the “Package” tab, select the “ThinApp” tab of 
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the second level and click the “Build ThinApp” button. 

 

 

3.8 Edit an Existent Package File 

3.8.1 Open a package 

[1]. Launch MSI Generator. 

 

[2]. If you have User Account Control enabled, click the “Yes” button in the opened UAC 

window. 

[3]. Select “Edit package”. 
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[4]. Select a package file (*.mgp) and click Open. 

 

3.8.2 File and folders 

[1]. Follow the instructions on how to Open a package from step 1 to 4. 

[2]. Navigate to the “Files” tab. 

This tab is designed to show all files and folders, which were added, modified or removed 

during the repackaging process. MSI Generator uses exclusion lists for detecting which of 

captured files are system temporary files and should not be included to a package. Such 

unnecessary files will be marked as Excluded resources and they are shown in the right 

panel of the File tab.  The rest of files, which will be Included to a package are shown in the 
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left panel. 

 

Use “Tree View” (right top corner) to get structured view of resources and have ability to 

perform Include and Exclude operations on folders, not only files.  

 

3.8.2.1 Exclude captured files and folders 

[1]. Follow the instructions on how to Open a package from step 1 to 4. 

[2]. Navigate to the “Files” tab. 
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[3]. Select unnecessary resources and choose “Exclude” from the context menu, click the 

“Exclude” button, or press Del. 

 

3.8.2.2 Include captured files and folders 

[1]. Follow the instructions on how to Open a package from step 1 to 4. 

[2]. Navigate to the “Files” tab. 

[3]. Select desired resources and choose “Include” from the context menu or click the 

“Include” button. 
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When a resource is included, it is moved to the left panel. 

3.8.2.3 Create a new empty folder 

[1]. Follow the instructions on how to Open a package from step 1 to 4. 

[2]. Navigate to the “Files” tab. 

[3]. Select a parent folder in which new folder will be created and choose “New folder” in 

the context menu or click the “New folder” button. 

 

[4]. Enter the name of a new folder and click “Create” 

 

3.8.2.4 Import files or folders 

[1]. Follow the instructions on how to Open a package from step 1 to 4. 

[2]. Navigate to the “Files” tab. 

[3]. To import files, select a desired destination directory and choose “Import files” in the 

context menu or click the “Import files” button. 
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[4]. Select files to be imported and click “Open” 

 

[5]. To import folder with all its files and subfolders, select a desired destination directory 

and choose  “Import folder with files” in the context menu or click the “Import folder with 

files” button. 
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[6]. Select a folder to be imported and click “OK” 

 

3.8.2.5 Set App-V virtualization levels for folders 

[1]. Follow the instructions on how to Open a package from step 1 to 4. 

[2]. Navigate to the “Files” tab. 

[3]. Select a folder, for which you want to change the App-V virtualization level and choose 

“Override local directory” or “Merge with local directory” from the “App-V options” 

submenu of context menu. 
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3.8.3 Registry entries 

[1]. Follow the instructions on how to Open a package from step 1 to 4. 

[2]. Navigate to the “Registry” tab. 

This tab is designed to show all registry entries, which were added, modified or removed 

during the repackaging process. MSI Generator uses its exclusion lists for detecting which of 

captured registry entries are system temporary and should not be included to a package. 

Such unnecessary registry entries will be marked as Excluded resources and they are shown 

in the right panel of the Registry tab. The rest of registry entries, which will be Included to a 

package are shown in the left panel. 
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Use “Tree View” (right top corner) to get structured view of resources and have ability to 

perform Include and Exclude operations on whole registry key.  

 

3.8.3.1 Exclude captured registry entries 

[1]. Follow the instructions on how to Open a package from step 1 to 4. 

[2]. Navigate to the “Registry” tab. 

[3]. Select unnecessary resources and choose “Exclude” from the context menu or click the 

“Exclude” button. 
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Moving selected registry entries to the right panel means that resources were excluded 

successfully. 

3.8.3.2 Include captured registry entries 

[1]. Follow the instructions on how to Open a package from step 1 to 4. 

[2]. Navigate to the “Registry” tab. 

[3]. Select desired resources and choose “Include” from the context menu or click the 

“Include” button. 
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Moving selected registry entries to the left panel means that resources were included 

successfully. 

3.8.3.3 Import REG file 

[1]. Follow the instructions on how to Open a package from step 1 to 4. 

[2]. Navigate to the “Registry” tab. 

[3]. Select desired resources and choose “Import registry” from the context menu or click 

the “Import registry” button. 

 

[4]. Choose REG file to be imported and click “Open”. 

 



Getting Started 
PACE Suite 4.1 

pg. 38 

3.8.3.4 Export captured registry to REG file 

[1]. Follow the instructions on how to Open a package from step 1 to 4. 

[2]. Navigate to the “Registry” tab. 

[3]. Select a registry key and choose “Export” in the context menu of click the “Export” 

button. 

 

[4]. Select the name and destination location of a new REG file and click “Save” 

 

3.8.3.5 Set App-V virtualization levels for registry keys 

[1]. Follow the instructions on how to Open a package from step 1 to 4. 
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[2]. Navigate to the “Registry” tab. 

[3]. Select a registry key, for which you want to change the App-V virtualization level and 

choose “Override local key” or “Merge with local key” from the “App-V options” submenu 

of context menu. 

 

3.8.4 Shortcuts and App-V FTAs 

[1]. Follow the instructions on how to Open a package from step 1 to 4. 

[2]. Navigate to the “Shortcuts and FTAs” tab. 

This tab is designed to show all shortcuts and App-V File Type Associations (FTAs) that were 

added or modified during the repackaging process. MSI Generator allows changing 

shortcut’s name, destination folder, target path, working directory, import new icon, convert 

shortcut to advertised and non-advertised. Also it allows modifying existing and creating 

new App-V File Type Associations. 
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3.8.4.1 Import a shortcut 

[1]. Follow the instructions on how to Open a package from step 1 to 4. 

[2]. Navigate to the “Shortcuts and FTAs” tab. 

[3]. First, please ensure that the package contains a desired destination folder path for a 

new shortcut. To do so, navigate to the “Files” tab and create new folders if needed (refer to 

Create a new empty folder). 

NOTE That standard location of Start Menu shortcuts is the following: 

           C:\ProgramData\Microsoft\Windows\Start Menu\Programs 
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[4]. Go back to the “Shortcuts” tab and click the “Import shortcuts” button 

 

[5]. Select a desired destination location folder for new shortcut and click “OK” 
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[6]. Choose a shortcut to be imported and click “Open” 

 

3.8.4.2 Create a new App-V FTA 

[1]. Follow the instructions on how to Open a package from step 1 to 4. 

[2]. Navigate to the “Shortcuts and FTAs” tab. 

[3]. Click on the “New” button that is located in the right pane. 
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[4]. In the opened “File type association” dialog, enter all required data such as “Extension”, 

“ProgId”, “Actions” and click the “Save” button. 

 

3.9 Edit an MSI package 

3.9.1 Open an MSI 

[1]. Launch “MSI Editor” 
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[2]. Select “MENU” -> “Open…” 

 

[3]. Choose an MSI or MST file and click “Open” 
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A content of the selected file will be displayed if a file is valid and successfully opened, 

otherwise the respective error message will be displayed. 

 

3.9.2 Add a Standard Folder 

[1]. Follow the instructions on how to Open an MSI from step 1 to 3. 

[2]. Navigate to the “Files” tab. 

[3]. Click “Add” -> “New standard folder” and select desired standard MSI folder from list. 

This list contains only those folders that do not exist in the opened MSI. 
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3.9.3 Create a new folder 

[1]. Follow the instructions on how to Open an MSI from step 1 to 3. 

[2]. Navigate to the “Files” tab. 

[3]. Select “New custom folder” from context menu of the folder, in which a new folder will 

be created. Alternatively, choose a destination folder, which a new folder will be created 

and click “Add” -> “New custom folder” 
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[4]. Enter the name of a new folder and click “Create” 

 

3.9.4 Import files 

[1]. Follow the instructions on how to Open an MSI from step 1 to 3. 

[2]. Navigate to the “Files” tab. 

[3]. Select “Import files…” from the context menu of folder, in which new files or folder will 

be imported.  
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[4]. Click “Add” -> “Select files…” to import one or more files, or click “Add” -> “Select 

folder…” to import a folder with its complete content 

 

[5]. Choose files to import and click “Open” 

 

[6]. Click “Next” to go the “Settings” step and select additional option such as target feature, 

media type and how to treat INI files. 
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Alternatively, choose “Complete operation with default settings” checkbox and click “Next” 

to complete the file import with default settings. 

 

[7]. “Settings” step allows controlling how to install INI files, what feature will be used for 

new components and how to save imported files. The following settings are available (see 

screenshot below): 

Install standard INI files via IniFile 

table; non-standard via Files table 

(recommended) 

INI files that do not contain comments or duplicates 

will be saved to the IniFile table. All other INI files will 

be saved to the File table as regular files. 

Install all INI files via File table 
All INI files will be saved only to the File table as 

regular files. 

Install all INI files via File table and 

duplicate to IniFile table 

All INI files files will be saved to the File table as 

regular files and additionally all these INI files will be 

duplicated to the IniFile table (comments won’t be 
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saved to IniFile table; duplicated sections or keys will 

be merged). It allows update INI file values keeping 

initial order of the INI sections and file structure. 

Feature 
A feature, to which new components of imported 

files will be assigned. 

Create new feature 

New feature “PACE_Complete” for per-machine files 

and feature “PACE_UserPart” for per-user files will be 

created. “PACE_UserPart” will be parent feature for 

“PACE_Complete feature. 

Media type 

“New Cab file” – compress imported files into 

external CAB file 

“Uncompressed” – copy imported files to the folder 

of MSI package 

“Existing” – compress imported files into existing 

external CAB file 

Click “Next” to go the “Import COM” step to extract registration information from COM 

objects. 

Alternatively, choose “Complete operation with default settings” checkbox and click “Next” 

to complete the file import with selected settings. 

 

[8]. MSI Editor extracts registration information of imported COM objects (.dll, ocx, .tlb) and 

shows it in the table. Check the “Import COM information” checkbox to import extracted 

information to MSI. 

Click “Finish” to complete the file import. 
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3.9.5 Extract COM information from files  

MSI Editor allows extracting registration information of COM objects from imported files 

(*.DLL, *.OCX, *.LTB). This feature is available via “Import files”, please refer to Import files 

(pay attention to the last step). 

3.9.6 Create a new registry key 

[1]. Follow the instructions on how to Open an MSI from step 1 to 3. 

[2]. Navigate to the “Registry” tab. 

[3]. Select “New key” from the context menu of a registry key, in which a new key will be 

created. Alternatively, select a registry key, which a new key will be created and click “Add”, 

-> “New key”. 
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[4]. Use “Rename” from the context menu to specify a new name of the registry key. 

 

3.9.7 Create a new registry value 

[1]. Follow the instructions on how to Open an MSI from step 1 to 3. 

[2]. Navigate to the “Registry” tab. 

[3]. Select “New value…” from the context menu of a registry key, in which a new value will 

be created. Alternatively, select a registry key, which a new key will be created and click 

“Add”, -> “New value…”. 



Getting Started 
PACE Suite 4.1 

pg. 53 

 

[4]. Enter the name, value, select value type and component from the list. Click “Add” to 

create the value. 

 

3.9.8 Import a REG file 

[1]. Follow the instructions on how to Open an MSI from step 1 to 3. 

[2]. Navigate to the “Registry” tab. 

[3]. Click “Add” -> “Import registry…”. 
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[4]. Choose a registry file (*.REG) to import and click “Open”. 

 

[5]. Click “Add” to select more REG files. 

To remove any entry from the list, select it and click “Remove”. 

Click “Next” to go the “Settings” step. Alternatively, choose “Complete operation with 

default settings” checkbox and click “Next” to complete the import with default settings. 
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[8]. “Settings” step allows controlling what feature will be used for new components: 

Feature 
A feature, to which new components of imported 

registry will be assigned.  

Create new feature 

New feature “PACE_Complete” for per-machine 

registry entries and feature “PACE_UserPart” for 

per-user registry entries will be created. 

“PACE_UserPart” will be parent for 

“PACE_Complete”. 

If unsure, check the “Create new features” checkbox. 

Click “Finish” to complete the import.  

 

3.9.9 Import Merge Module (MSM) 

[1]. Follow the instructions on how to Open an MSI from step 1 to 3. 
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[2]. Select “MENU” -> “Add and import” -> “Import merge modules…”. 

 

[3]. Click the “Add” button to choose merge modules to import. 

 

[4]. Choose merge modules (*.MSM) and click “Open” 
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[5]. Use the “Add” and “Remove” buttons to add more merge modules or remove selected 

ones. 

Click “Next” to go the “Settings” step. Alternatively, choose “Complete operation with 

default settings” checkbox and click “Next” to complete the import with default settings. 

 

[6]. “Settings” step allows controlling what feature will be used for merge modules, directory 

for merge modules’ resources and media type: 

Root Directory A target directory for merge modules’ resources 

Primary Feature 
Feature to which merge modules’ components will 

be assigned. 
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Media type 

“External Cab” – compress merge modules’ 

resources into external CAB file. 

“Uncompressed” – copy merge modules’ resources 

to the folder of MSI package 

If unsure, leave default settings. 

Click “Finish” to complete the Merge Module import.  

 

3.9.10 Import upgrade info from older MSIs 

[1]. Follow the instructions on how to Open an MSI from step 1 to 3. 

[2]. Click “Import upgrades…” to choose previous MSI packages. 

 

[3]. Choose MSI files, which are need to be upgraded and click “Open” 
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[4]. Successfully imported upgrade codes will be shown in the pop-up window. 

Click “Ok” to close the window. 

 

3.9.11 Change ARP icon 

[1]. Follow the instructions on how to Open an MSI from step 1 to 3. 

[2]. Click on icon to view existing elements and pick one of icons from the list. 
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[3]. To set the default icon, click on the  button.  

 

[4]. To import an icon from a file (*.DLL, *.EXE, *.ICO), click on the “Browse” button. 

 

[5]. Choose an icon containing file and click “Open” 
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[6]. Select a desired icon from the list and click “OK” to import it to the opened MSI 

package. 

 

3.9.12 Import shortcuts 

[1]. Follow the instructions on how to Open an MSI from step 1 to 3. 

[2]. Navigate to the “Shortcuts” tab. 

[3]. Click “Add” -> “Import shortcuts…” to choose shortcuts to import. 
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[4]. Choose shortcut files (*.LNK, *.URL) and click “Open” 

 

3.9.13 Create a new shortcut 

[1]. Follow the instructions on how to Open an MSI from step 1 to 3. 

[2]. Navigate to the “Shortcuts” tab. 

[3]. Click “Add” -> “New shortcut to file/folder…” to create a new shortcut to a file or folder 

inside the MSI. 
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[4]. Choose a file or a folder as a shortcut target and click “Select” 

 

[5]. Edit attributes and icon of newly created shortcut if needed 
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3.9.14 Toggle non-advertised/advertised shortcut 

[1]. Follow the instructions on how to Open an MSI from step 1 to 3. 

[2]. Navigate to the “Shortcuts” tab. 

[3]. Select a shortcut in the shortcut list and check the “Advertised” checkbox to convert it to 

an advertised one. 

 

An advertised shortcut is a special shortcut which triggers Windows Installer to validate (and 

“self-heal”, if missing or broken) the key resources associated with it, every time a shortcut is 

launched by a user. For more details, please refer to MSDN (https://msdn.microsoft.com/en-

us/library/aa367548(v=vs.85).aspx) 

3.10 Create a Patch (MSP) 

There are two options in MSI Editor to create a Windows Installer Patch: 

https://msdn.microsoft.com/en-us/library/aa367548(v=vs.85).aspx
https://msdn.microsoft.com/en-us/library/aa367548(v=vs.85).aspx)
https://msdn.microsoft.com/en-us/library/aa367548(v=vs.85).aspx)
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 Save changes as patch 

This approach allows saving (exporting) all changes, which user made to the opened MSI 

package, as a Patch. Note that only unsaved changes will be put into a Patch. 

 

 Create patch against original MSI 

This option is used for creating a Patch, based on differences between the opened and the 

selected ‘Original MSI’ packages. The ‘Original MSI’ package is usually a previous version of 

the currently opened MSI package. 

3.10.1 Save changes as patch 

[1]. Follow the instructions on how to Open an MSI from step 1 to 3. 

[2]. Select “MENU” -> “Save as MSP” in the main menu.  

 

[3]. Increase “Product version” for minor and major update and leave default value for small 

update. Generate new “Product code” only for major update and leave default value for 

minor and small update. Update the “Target product name” field in order to change 

Product Name of updated application. Click the “Next” button to continue. 
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[4]. Change Patch properties according to your needs and click the “Create” button 

 

[5]. Wait while Patch is creating 
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[6]. Choose a destination location for the successfully created Patch file and click the “Save” 

button. 

 

3.10.2 Create patch against original MSI 

[1]. Follow the instructions on how to Open an MSI from step 1 to 3. 

[2]. Select “MENU” -> “Save as MSP” in the main menu.  
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[3]. Click to the “Browse…” button and choose an original MSI package (initial, previous 

version of the current package) 

 

[4]. Select the original package and click “Open” 



Getting Started 
PACE Suite 4.1 

pg. 69 

 

[5]. Click the “Next” button to continue 

 

[6]. For next steps use instruction on Save changes as patch 

3.11 Publish to SCCM 

NOTE Please ensure that a target system contains necessary software: 

Prerequisites 

 Microsoft SCCM server version: SCCM 2007 (SP1/SP2/R1/R2) or 

SCCM 2012 (SP1/SP2/R2/R2 SP1) 

 Microsoft Management Framework 3.0 

 Windows Remote Management (WinRM) service enabled 

[1]. Follow the instructions on how to Open an MSI from step 1 to 3. 
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[2]. Select “MENU” -> “Publish package to SCCM…” in the main menu.  

 

[3]. Specify your SCCM setting and click “Next” 

 

[4]. Choose one of publishing model and click “Next” 

NOTE That the “Publish as an Application” option is available only for SCCM 2012. 
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[5]. If needed, update package display information and click “Next” 

 

[6]. The “Publish options” step serves publishing options, which are different for ‘application’ 

and ‘package’ models. Specify required publishing options and click “Next”. 

Publish options for ‘package model’: 
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[7]. Select which files should be copied to the network share for packages and click “Next” 

 

[8]. Wait for the result message about publishing package to SCCM server. 
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3.12 Generate a package report 

NOTE PACE Suite supports only Word Document (.DOCX) and Excel Workbook (.XLSX) format   

           types and allows generating a report with no Microsoft Office installed on the system. 

[1]. Follow the instructions on how to Open an MSI from step 1 to 3. 

[2]. Select “MENU” -> “Generate package report…” in the main menu.  
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[3]. Select the default PACE template (PACE – Package Report.docx) or your custom 

template (find more info by clicking the “How to create a new template” link in the dialog) 

and click the “Generate” button 

 

[4]. Wait few seconds while package report is generating. Once it is done, choose a 

destination location  for the generated file using the appeared Save As dialog and click 

“Save” 
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3.13 Package Quality Assistant 

[1]. Follow the instructions on how to Open an MSI from step 1 to 3. 

[2]. Select “MENU” ->”Validation” -> “Package quality assistant” 
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[3]. Once the validation process is started, the respective busy box is displayed. Just wait few 

seconds 
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[4]. Validation results will be shown in the “ICE Validation” panel of the “Tables” tab. You will 

be switched to this view automatically. 

 

[5]. Currently, defining own custom rules for Package Quality Assistant is possible only via 

manual editing of the “Common.xml” file, which is located at the: “C:\Program Files 

(x86)\PACE Suite\MSI Editor\ExternalTools\QualityAssistant\Projects\checklists\” directory. 

3.14 Package Complexity Estimation 

[1]. Follow the instructions on how to Open an MSI from step 1 to 3. 
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[2]. Click the “Refresh” button at “Complexity Estimation” panel to re-calculate complexity 

level. 

 

[3]. In order to export complexity estimation results, click the “Export Results” button at the 

“Complexity Estimation” panel. 

 

 

[4]. Choose a destination location of a file with the exported complexity estimation results 

using the appeared Save As dialog and click “Save” 
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[5]. If needed, you modify default complexity calculation rules in the ComplexityConfig.xml 

file, which is located at the “%USERPROFILE%\MSI Editor\” directory. 

 

3.15 Using Docu Generator 

To create an application package that fulfills the requirements and expectations, you need to know 

clearly how the application has to be installed and configured step-by-step. This includes (but is not 

limited to): 

 Installer files to be launched and features to be installed 

 Options to be specified in installation dialogs 

 License keys to be used 

 Application settings (e.g. startup screen disabled, connection settings specified) to be pre-

configured by the package 

 Desired shortcuts and their location. 

While this information may be obvious for some installations (e.g. a simple next…next one without a 

choice), its description is essential for another complicated ones. 

It is recommended to agree on a standard form of an Installation and configuration instruction and 

make it available along with original software installations. 

Docu Generator helps to automate the creation of such documentation. 
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Follow the steps below to create an installation and configuration instruction with Docu Generator. 

Provide these steps to your requester if you wish to ask them to create such documents. 

3.15.1 Launch Docu Generator and Start Recording 

Launch Docu Generator. On the Home 

screen, click “Record Scenario”.  

Scenario is user actions recorded by 

Docu Generator as a series of 

screenshots and annotations. A scenario 

can be saved in internal Docu 

Generator format (DSCN file) or as a 

document (DOC, HTML, MHT). 

3.15.2 Control Recording 

The recording window will appear in 

the lower right corner of your 

desktop providing you the following 

controls: 

“Pause”, “Continue” – Click to pause 

recording. Click again to resume; 

“Stop” – stop recording and proceed 

to saving results; 

“Hot Keys” – Hover to see a hint of Hot Keys. Click to edit Hot Keys  

3.15.3 Take Screenshots 

Now, do the actions you want to 

record into the document. Launch 

executables, go through dialogs, 

select options and enter values just 

telling Docu Generator when to take 

another screenshot, as described 

below. 

To take a screenshot: 

Window/Smart area screenshot 
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Hold left Shift key when clicking. This will make Docu Generator grab a window or 

dialog/message box you’ve clicked on. If you’ve clicked outside any window (e.g. on desktop 

shortcut), then a smartly chosen rectangular area around mouse pointer will be grabbed. 

Executable path, a window title, names of clicked buttons or other controls, contents of text 

fields from a captured window are automatically grabbed into textual annotations. Yet 

inclusion of this information into a target document can be controlled when saving. 

Custom area screenshot 

Press Ctrl+Shift+PrintScreen, then click and drag the mouse pointer to select a rectangular 

area you want to grab. A screenshot is done when you release the mouse button. 

A preview of each new screenshot immediately appears in the Recording window. 

3.15.4 Manage Screenshots 

Hover the mouse pointer over a preview of a screenshot in the 

Recording Window to access its options 

Edit annotation… – Edit an annotation for the screenshot; 

Copy to clipboard – Copy the screenshot to clipboard for 

immediate use; 

Remove – Delete the screenshot (preceded by a prompt). 

Hover the mouse pointer over a preview for another moment to view the screenshot enlarged. 

3.15.5 Add Annotations 

To add a text annotation to the 

latest screenshot, click the “Add 

Annotation” button in Recording 

window or use the Ctrl+Alt+X 

hotkey. Enter annotation text in 

the “Add Annotation” window 

and click the “Add” button. 

 

 

3.15.6 Save results 

When done, click “Stop” in the Recording window. The Save Results window will appear: 
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Use the “Save as” switch to select the output format. The following output formats are supported: 

Word Document – the scenario will be saved as a series of screenshots and annotations into 

a DOC file; 

MHT/HTML File – the scenario will be saved as a series of screenshots and annotations into a 

HTML (Web page) or MHT (Web archive) file. A file type can be selected in a dialog box after 

clicking Save; 

Docu Generator Scenario – the scenario will be saved in internal Docu Generator format 

(DSCN file) which can be opened with Docu Generator and converted to an output document 

later. 

NOTE To let you return to your scenario later, Docu Generator always creates DSCN file along  

           with the output file in an output folder. 

 

NOTE If Microsoft Word is unavailable on the machine, the option of saving DOC file is inactive,  

           but you still can save a DSCN file and convert it on a machine with MS Office installed later. 

Use the “Template” field to point Docu Generator to a template to be used for the output document. 

Please see the next step for details. 

The “Options” pane allows controlling the following information inclusion to the output document: 

Save user actions – this option adds to the document the information about names of controls 

(which were clicked on) and names of the captured windows and dialog boxes. 

Show mouse position – this option adds to the document information about mouse pointer 

position and highlight it with a red circle on screenshots; 
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Show started application info – this option adds to the document information about paths 

and command line arguments of the launched application; 

Show contents of edited fields – this option adds to the document contents of input fields of 

the captured windows and dialog boxes. 

Click the “Save” button to save the document. The document will be automatically opened in a 

default viewer, and Docu Generator will be closed. 

3.15.7 Use Document Templates 

Docu Generator supports Microsoft Word (DOT/DOTX) and HTML/MHT templates to be used for 

document creation. To use a template, specify its file path in the “Save Results” window (see previous 

step). 

In order to mark a position where screenshots and comments are to be placed to, add the following 

textual placeholder into a template: 

[SCR] 

You can specify placeholder [SCR] in the existing table in a template. In this case the placeholder 

points to a cell where screenshots should start, while a column to the right of it will be populated 

with comments. 

If the placeholder is located outside a table, then a new table for screenshots and comments will be 

created. A Docu Generator-default table style will be used. 

If a placeholder is not found, screenshots and comments will be appended to the end of the 

template. You’ll be warned about this in the Save Results window: 

 

 

4 References 

4.1 More information and contact 

 

Product website http://pacesuite.com  

  

Support email pace-support@infopulse.com  

  

http://pacesuite.com/
mailto:pace-support@infopulse.com
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Support Portal http://pacesuite.com/support 

 

 

4.2 PACE Suite in social and professional networks 

 

 
itninja.com/pace  

  

 
@pacesuite  

  

 fb.com/pacesuite 

  

 
https://www.linkedin.com/groups/PACE-Suite-APS-

community-4765703 

 

 

http://pacesuite.com/support/
http://itninja.com/pace
https://twitter.com/pacesuite
https://fb.com/pacesuite
https://www.linkedin.com/groups/PACE-Suite-APS-community-4765703
https://www.linkedin.com/groups/PACE-Suite-APS-community-4765703
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